summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/colorlog/colorlog-2.6.0.ebuild')
-rw-r--r--dev-python/colorlog/colorlog-2.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/colorlog/colorlog-2.6.0.ebuild b/dev-python/colorlog/colorlog-2.6.0.ebuild
new file mode 100644
index 000000000000..a586d01e0064
--- /dev/null
+++ b/dev-python/colorlog/colorlog-2.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Log formatting with colors"
+HOMEPAGE="https://pypi.python.org/pypi/colorlog https://github.com/borntyping/python-colorlog"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+python_test() {
+ py.test colorlog || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( doc/. )
+ distutils-r1_python_install_all
+}