summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/crumbs/crumbs-2.0.0.ebuild')
-rw-r--r--dev-python/crumbs/crumbs-2.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/crumbs/crumbs-2.0.0.ebuild b/dev-python/crumbs/crumbs-2.0.0.ebuild
new file mode 100644
index 000000000000..23bc8832bdb5
--- /dev/null
+++ b/dev-python/crumbs/crumbs-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generalized all-in-one parameters module"
+HOMEPAGE="https://github.com/alunduil/crumbs"
+SRC_URI="https://github.com/alunduil/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="inotify test"
+
+CDEPEND="inotify? ( dev-python/pyinotify[${PYTHON_USEDEP}] )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests || die "Tests failed on ${EPYTHON}"
+}