summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild')
-rw-r--r--dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild b/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
deleted file mode 100644
index 9fa4f75ce881..000000000000
--- a/dev-python/django-auth-ldap/django-auth-ldap-1.7.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Django LDAP authentication backend"
-HOMEPAGE="https://pypi.org/project/django-auth-ldap/ https://bitbucket.org/psagers/django-auth-ldap/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-LICENSE="BSD"
-SLOT="0"
-
-RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]
- >=dev-python/python-ldap-3.1[${PYTHON_USEDEP}]"
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}