summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-pglocks')
-rw-r--r--dev-python/django-pglocks/django-pglocks-1.0.4.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild b/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
index 8c8a7fe0b70f..00a09d61df5b 100644
--- a/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
+++ b/dev-python/django-pglocks/django-pglocks-1.0.4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_6 python3_7 )
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="PostgreSQL locking context managers and functions for Django"
@@ -14,7 +15,5 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-DEPEND="
- >=dev-python/six-1.0.0[${PYTHON_USEDEP}]
- "
+DEPEND=">=dev-python/six-1.0.0[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"