summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/google-auth/google-auth-1.0.1.ebuild')
-rw-r--r--dev-python/google-auth/google-auth-1.0.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/google-auth/google-auth-1.0.1.ebuild b/dev-python/google-auth/google-auth-1.0.1.ebuild
deleted file mode 100644
index 553ccb457d1c..000000000000
--- a/dev-python/google-auth/google-auth-1.0.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # urllib3-1.16 raised MaxRetryError, not TransportError
- sed -e 's:test_connection_error:_\0:' -i tests/transport/compliance.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # delete stray files included in the tarball
- find "${S}"/tests -name '*.pyc' -delete || die
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}