summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hyper-h2/hyper-h2-3.0.0.ebuild')
-rw-r--r--dev-python/hyper-h2/hyper-h2-3.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hyper-h2/hyper-h2-3.0.0.ebuild b/dev-python/hyper-h2/hyper-h2-3.0.0.ebuild
new file mode 100644
index 000000000000..63055a4f939f
--- /dev/null
+++ b/dev-python/hyper-h2/hyper-h2-3.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+MY_PN="h2"
+
+DESCRIPTION="HTTP/2 State-Machine based protocol implementation"
+HOMEPAGE="http://python-hyper.org/h2 https://pypi.python.org/pypi/h2"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/hyperframe-5.0.0[${PYTHON_USEDEP}]
+ <dev-python/hyperframe-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hpack-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/hpack-3.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/enum34-1.1.6[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep '<dev-python/enum34-2.0.0[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="${RDEPEND}
+"
+
+S=${WORKDIR}/${MY_PN}-${PV}