summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/keyring/keyring-3.3.ebuild')
-rw-r--r--dev-python/keyring/keyring-3.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keyring/keyring-3.3.ebuild b/dev-python/keyring/keyring-3.3.ebuild
new file mode 100644
index 000000000000..9e502ea3f5bc
--- /dev/null
+++ b/dev-python/keyring/keyring-3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 pypy)
+
+inherit distutils-r1
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://bitbucket.org/kang/python-keyring-lib"
+SRC_URI="mirror://pypi/k/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pycrypto[$(python_gen_usedep 'python2*' 'python3*')] )"
+RDEPEND=""
+
+python_test() {
+ py.test || die "testsuite failed under ${EPYTHON}"
+}