summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ldap3/ldap3-2.2.3.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-2.2.3.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/ldap3/ldap3-2.2.3.ebuild b/dev-python/ldap3/ldap3-2.2.3.ebuild
index 79692644bb5c..14c5331f093b 100644
--- a/dev-python/ldap3/ldap3-2.2.3.ebuild
+++ b/dev-python/ldap3/ldap3-2.2.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,11 +20,14 @@ IUSE="test"
# https://github.com/cannatag/ldap3/blob/master/test/config.py).
RESTRICT="test"
-RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]"
+
+DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- "
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ ${RDEPEND} )"
python_test() {
nosetests -v -s test || die