summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpmath')
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/files/mpmath-1.0.0.patch9
-rw-r--r--dev-python/mpmath/mpmath-1.0.0.ebuild42
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index c09501166a75..710b5dcace9b 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1,2 +1,3 @@
+DIST mpmath-1.0.0.tar.gz 511349 SHA256 d32ba7afffbae688229a15f54fbc37c11f4989e4fac628c99b3c5b6889aee03d SHA512 b225f237008e1cfee52b2f0dca0dce1445b932b6eaef92879d7feca30d728e3f88810bfa80882ad8776ba846a636807e59bebe0b9f690cd878c089e9418bd8b7 WHIRLPOOL 5dc18ab6f81a529c06bcc968dd3e9da0a5123740b2a5b2829e98b303b5e3d8208956122a7fd7698ad275d4246aafcbd1756bc0922801d32a535b809cf749b3ac
DIST mpmath-all-0.18.tar.gz 2122954 SHA256 47cc9587ea10202cdfb1afce4fb7410821e91ae6ecb1b54d62be1adfce80ee40 SHA512 a22e1c82f33a30584c975d196601e7bddaf33d4a41b1f288216a9df038ba5a45fd1002c5aa5f15084d05bee3abad944168ad131ac7e4feb218aac22789d8a63f WHIRLPOOL 7544b09310fbb262f2a4f487fa29af429196142e3fcab5822c1383420c7d8948a70b0f505adc0ce4fd7c0e6b6936b8dc6832a5e3d92e7c7cb71d05f6343dd79a
DIST mpmath-all-0.19.tar.gz 2123129 SHA256 21a824db176799f42843e4510da4bc6db36ef92b5a43fff70fad7e29bffb9c86 SHA512 5a6ed0b5fad84c1e8399467ea7a1295f9b77c8e673b821c11e3298e88df6c48d9967eed84e2979bf12868e2f9b42bffba01a0c1836a6d82ac42d5f423fed6580 WHIRLPOOL 360fedc4d6942a138b33c63867f8a5e4ce4c101a8f7221c61503933e75073807676cbb240c9bddea765159cb134efd608256c9b921b7d282763b57d2897eefdb
diff --git a/dev-python/mpmath/files/mpmath-1.0.0.patch b/dev-python/mpmath/files/mpmath-1.0.0.patch
new file mode 100644
index 000000000000..3a88f38c9927
--- /dev/null
+++ b/dev-python/mpmath/files/mpmath-1.0.0.patch
@@ -0,0 +1,9 @@
+diff -r -U1 mpmath-1.0.0.orig/setup.py mpmath-1.0.0/setup.py
+--- mpmath-1.0.0.orig/setup.py 2017-09-27 21:42:12.000000000 +0700
++++ mpmath-1.0.0/setup.py 2017-10-02 20:36:02.919554100 +0700
+@@ -15,4 +15,3 @@
+ 'mpmath.functions',
+- 'mpmath.matrices',
+- 'mpmath.tests'],
++ 'mpmath.matrices'],
+ classifiers=['Topic :: Scientific/Engineering :: Mathematics']
diff --git a/dev-python/mpmath/mpmath-1.0.0.ebuild b/dev-python/mpmath/mpmath-1.0.0.ebuild
new file mode 100644
index 000000000000..06c4d2848519
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="http://mpmath.org/"
+SRC_URI="http://mpmath.org/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE="gmp matplotlib test"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}.patch"
+ )
+
+ # this fails with the current version of dev-python/py
+ rm ${PN}/conftest.py || die
+
+ # this test requires X
+ rm ${PN}/tests/test_visualization.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die
+}