summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/mypy-0.700.ebuild2
-rw-r--r--dev-python/mypy/mypy-0.701.ebuild2
-rw-r--r--dev-python/mypy/mypy-0.740.ebuild2
-rw-r--r--dev-python/mypy/mypy-0.750.ebuild2
4 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/mypy/mypy-0.700.ebuild b/dev-python/mypy/mypy-0.700.ebuild
index caf10d3393dc..05da31d847a9 100644
--- a/dev-python/mypy/mypy-0.700.ebuild
+++ b/dev-python/mypy/mypy-0.700.ebuild
@@ -43,6 +43,8 @@ CDEPEND="
RDEPEND="${CDEPEND}"
+RESTRICT="!test? ( test )"
+
src_unpack() {
if [ "${PV}" == "9999" ]; then
git-r3_src_unpack
diff --git a/dev-python/mypy/mypy-0.701.ebuild b/dev-python/mypy/mypy-0.701.ebuild
index 6d104eec990e..8930f1f8dee8 100644
--- a/dev-python/mypy/mypy-0.701.ebuild
+++ b/dev-python/mypy/mypy-0.701.ebuild
@@ -43,6 +43,8 @@ CDEPEND="
RDEPEND="${CDEPEND}"
+RESTRICT="!test? ( test )"
+
src_unpack() {
if [ "${PV}" == "9999" ]; then
git-r3_src_unpack
diff --git a/dev-python/mypy/mypy-0.740.ebuild b/dev-python/mypy/mypy-0.740.ebuild
index 40b579062abc..59d0673680bb 100644
--- a/dev-python/mypy/mypy-0.740.ebuild
+++ b/dev-python/mypy/mypy-0.740.ebuild
@@ -43,6 +43,8 @@ CDEPEND="
RDEPEND="${CDEPEND}"
+RESTRICT="!test? ( test )"
+
src_unpack() {
if [ "${PV}" == "9999" ]; then
git-r3_src_unpack
diff --git a/dev-python/mypy/mypy-0.750.ebuild b/dev-python/mypy/mypy-0.750.ebuild
index 5301bd6fecbf..05d2fa5711c7 100644
--- a/dev-python/mypy/mypy-0.750.ebuild
+++ b/dev-python/mypy/mypy-0.750.ebuild
@@ -43,6 +43,8 @@ CDEPEND="
RDEPEND="${CDEPEND}"
+RESTRICT="!test? ( test )"
+
src_unpack() {
if [ "${PV}" == "9999" ]; then
git-r3_src_unpack