summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/packaging-15.3-r1.ebuild2
-rw-r--r--dev-python/packaging/packaging-15.3-r2.ebuild32
2 files changed, 1 insertions, 33 deletions
diff --git a/dev-python/packaging/packaging-15.3-r1.ebuild b/dev-python/packaging/packaging-15.3-r1.ebuild
index 80062fed5ece..bd92da65a30b 100644
--- a/dev-python/packaging/packaging-15.3-r1.ebuild
+++ b/dev-python/packaging/packaging-15.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
diff --git a/dev-python/packaging/packaging-15.3-r2.ebuild b/dev-python/packaging/packaging-15.3-r2.ebuild
deleted file mode 100644
index 6d77cb96a087..000000000000
--- a/dev-python/packaging/packaging-15.3-r2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}"/${P}-setuptools.patch )
-
-python_test() {
- py.test --capture=no --strict -v || die
-}