summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pdoc/pdoc-0.3.1.ebuild')
-rw-r--r--dev-python/pdoc/pdoc-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pdoc/pdoc-0.3.1.ebuild b/dev-python/pdoc/pdoc-0.3.1.ebuild
new file mode 100644
index 000000000000..430dfe54605f
--- /dev/null
+++ b/dev-python/pdoc/pdoc-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple program and library to auto generate API documentation for Python modules"
+HOMEPAGE="https://pypi.python.org/pypi/pdoc https://github.com/BurntSushi/pdoc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Unlicense"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ "