summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/prompt_toolkit')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-1.0.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index 293db7e9ab9c..9473bc2fcaac 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -10,3 +10,4 @@ DIST prompt_toolkit-0.57.tar.gz 178829 SHA256 de6019e1ebe99647d1b6640f09a02961b2
DIST prompt_toolkit-0.58.tar.gz 191691 SHA256 11b5109858bf5480a4823f1d5f4c3e45e97e6f3d1c2024b06f54ca73314eaca3 SHA512 8183e2530c6e0f67495fe078034b21f0a9b9cb6c28f6cb58c18048729a82432e543b405977ee75ca06489c7e42d26701ee303b7861fa10abea7f231c3fccdd22 WHIRLPOOL 4236a4620c8d6a63ad22db6c69761362847f9230cb5f432ab4f8d17c3d9b297bdeb7893d1c3b8ba0e3eba7635323b76be7d3cc321a8f1baa6cea44898cd868f6
DIST prompt_toolkit-0.60.tar.gz 194250 SHA256 b44acc4cf3fb9f7331343ae170eac06f853a66e28cdd4ccfeee7c8dad0dec33d SHA512 df8dda4a97bf08009c2980cc288d13e2fc56b5e73f6544014f3ece9e807f3d070b3b493cf6e112d225b6d0610f6711e3fbc8dc29412155e93047dff3aca0bb78 WHIRLPOOL 1d795f413cf915680f201f181da380b82eaa1a5892356608544812ef2c6a530802240930a1e98ce0d1484aab9c44e1bfcb0482a111c4db89c46c4709fc72016b
DIST prompt_toolkit-1.0.0.tar.gz 212138 SHA256 5108ed9e6e40d28cb1dc90ba563987859231289700d0def999007b08f4f74ea4 SHA512 84908871df84d82b0fd0e31c1bef63b3dde38d8e3c1459d3d5466cfda68ef48477eba5a2d4c5af831e7a3fa42ab57c56f771f8050b53223638683cee27281647 WHIRLPOOL a141f2ed1bc57ef9b663877094c9fe3e4a751a59f72c327da479872bfdd48b7b70ba78f3d4be2c397acb699d2adf272a8df5c8db7b3999b2711dd1b62d4a3d0d
+DIST prompt_toolkit-1.0.3.tar.gz 221875 SHA256 805e026f0cbad27467e93f9dd3e3777718d401a62788c1e84ca038e967ad8ba2 SHA512 c7615c42c7923bb2cefb8db536405976975d25a7df110698e9664f205d3428b6bbf6ca2aba8b0d85957296fcac0bf65752d025cabdb25c80f149f9b92c0c445d WHIRLPOOL 61390865c3f6ad7ed258c481484b6da9211c6053761ed3716977f43b00697c79e3f24443ee4695c1a4d1aea2105e2cf171df92685d42be62ac508c4f3deeb9f1
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-1.0.3.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-1.0.3.ebuild
new file mode 100644
index 000000000000..497ac161bed5
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-1.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.python.org/pypi/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test || die
+}