summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyglet/pyglet-1.2.4.ebuild')
-rw-r--r--dev-python/pyglet/pyglet-1.2.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyglet/pyglet-1.2.4.ebuild b/dev-python/pyglet/pyglet-1.2.4.ebuild
new file mode 100644
index 000000000000..e4d237ce7670
--- /dev/null
+++ b/dev-python/pyglet/pyglet-1.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="http://www.pyglet.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://pyglet.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa examples gtk +openal"
+
+RDEPEND="
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib[alisp] )
+ gtk? ( x11-libs/gtk+:2 )
+ openal? ( media-libs/openal )"
+DEPEND="${RDEPEND}"
+# ffmpeg? ( media-libs/avbin-bin )
+
+# pyglet.gl.glx_info.GLXInfoException: pyglet requires an X server with GLX
+RESTRICT=test
+
+python_test() {
+ python_is_python3 && return
+ VIRTUALX_COMMAND="${PYTHON}"
+ virtualmake tests/test.py
+}
+
+python_install_all() {
+ DOCS=( NOTICE )
+ use examples && EXAMPLES=( examples )
+ distutils-r1_python_install_all
+}