summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyhcl/pyhcl-0.3.6.ebuild')
-rw-r--r--dev-python/pyhcl/pyhcl-0.3.6.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-python/pyhcl/pyhcl-0.3.6.ebuild b/dev-python/pyhcl/pyhcl-0.3.6.ebuild
deleted file mode 100644
index 9ed0dde3c5bd..000000000000
--- a/dev-python/pyhcl/pyhcl-0.3.6.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="HCL configuration parser for python"
-HOMEPAGE="https://github.com/virtuald/pyhcl"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/ply-3.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- sed -i -e "s/==.*$//" requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die
-}