summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-cache')
-rw-r--r--dev-python/pytest-cache/Manifest1
-rw-r--r--dev-python/pytest-cache/metadata.xml14
-rw-r--r--dev-python/pytest-cache/pytest-cache-1.0.ebuild23
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-cache/Manifest b/dev-python/pytest-cache/Manifest
new file mode 100644
index 000000000000..a6d0a3dfe025
--- /dev/null
+++ b/dev-python/pytest-cache/Manifest
@@ -0,0 +1 @@
+DIST pytest-cache-1.0.tar.gz 16242 SHA256 be7468edd4d3d83f1e844959fd6e3fd28e77a481440a7118d430130ea31b07a9 SHA512 55eb66718a45fb0ad8931780d96fa4715cf0d9f2568be2a1b08b3399d391b818a7ae8b2afeb74b50aaf8ec8f7f0d8da8e7a7483845a50e884822ca6ddbca03ea WHIRLPOOL f1610e5ae8505abc6f6175d029c5afb9e3fbc7d10ba31379305752ebd941209514a054e34d36c794270d4a9eb0001c71aeea9700431798f54a1b40013a3d77a2
diff --git a/dev-python/pytest-cache/metadata.xml b/dev-python/pytest-cache/metadata.xml
new file mode 100644
index 000000000000..f54c58057228
--- /dev/null
+++ b/dev-python/pytest-cache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pxml</remote-id>
+ <remote-id type="github">metagriffin/pxml</remote-id>
+ <remote-id type="bitbucket">hpk42/pytest-cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cache/pytest-cache-1.0.ebuild b/dev-python/pytest-cache/pytest-cache-1.0.ebuild
new file mode 100644
index 000000000000..6cf0b751da4b
--- /dev/null
+++ b/dev-python/pytest-cache/pytest-cache-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="mechanisms for caching across test runs"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-cache http://bitbucket.org/hpk42/pytest-cache/ http://pythonhosted.org/pytest-cache/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "