summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
new file mode 100644
index 000000000000..d6fc2826fc9e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://bitbucket.org/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ find -name __pycache__ -exec rm -r '{}' + || die
+ py.test -vv || die
+}