summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xdist')
-rw-r--r--dev-python/pytest-xdist/Manifest1
-rw-r--r--dev-python/pytest-xdist/metadata.xml14
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/Manifest b/dev-python/pytest-xdist/Manifest
new file mode 100644
index 000000000000..2a22275319ee
--- /dev/null
+++ b/dev-python/pytest-xdist/Manifest
@@ -0,0 +1 @@
+DIST pytest-xdist-1.13.1.tar.gz 110007 SHA256 4382d7a944c1e2b1dc17fee3fd3575495fb10236a3b6e95cc6955db04984bc3c SHA512 3bb295c0afbcb0f238bdd41dfd1a395f0ba16b8151643aecc25aae13ac7c58d36d26ff4bab197673a9679d1f3436acd05b5ff50107b3128e647de892a6d04e3f WHIRLPOOL 643b23c755eb43c7b6965e588b58547c9ef63d3c225cddb97868c659ab3234bc6bc204575bc48c7f18a498cb0e595b8550928ba92ec5945a936e959f773504b3
diff --git a/dev-python/pytest-xdist/metadata.xml b/dev-python/pytest-xdist/metadata.xml
new file mode 100644
index 000000000000..54c737351551
--- /dev/null
+++ b/dev-python/pytest-xdist/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pxml</remote-id>
+ <remote-id type="github">metagriffin/pxml</remote-id>
+ <remote-id type="bitbucket">pytest-dev/pytest-xdist</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
new file mode 100644
index 000000000000..d6fc2826fc9e
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-xdist https://bitbucket.org/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ find -name __pycache__ -exec rm -r '{}' + || die
+ py.test -vv || die
+}