summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-sense-hat')
-rw-r--r--dev-python/python-sense-hat/metadata.xml9
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild25
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-sense-hat/metadata.xml b/dev-python/python-sense-hat/metadata.xml
index 54d5423c4060..eb43e658b304 100644
--- a/dev-python/python-sense-hat/metadata.xml
+++ b/dev-python/python-sense-hat/metadata.xml
@@ -9,4 +9,13 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <longdescription>
+ Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission.
+ An education outreach programme for UK schools sending code experiments
+ to the International Space Station.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/RPi-Distro/python-sense-hat/issues</bugs-to>
+ <remote-id type="github">RPi-Distro/python-sense-hat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..fed87a383669
--- /dev/null
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
+SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"