summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis-py/redis-py-2.10.3.ebuild')
-rw-r--r--dev-python/redis-py/redis-py-2.10.3.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/dev-python/redis-py/redis-py-2.10.3.ebuild b/dev-python/redis-py/redis-py-2.10.3.ebuild
index b94bf89e9aa0..0ca1dc75e3dc 100644
--- a/dev-python/redis-py/redis-py-2.10.3.ebuild
+++ b/dev-python/redis-py/redis-py-2.10.3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1
@@ -47,14 +47,7 @@ python_compile() {
fi
}
-src_test() {
- # testsuite fails miserably under multiprocessing
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
python_test() {
-
local sock="${T}/redis.sock"
"${EPREFIX}/usr/sbin/redis-server" - <<- EOF