summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rosdistro/rosdistro-0.4.4.ebuild')
-rw-r--r--dev-python/rosdistro/rosdistro-0.4.4.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/rosdistro/rosdistro-0.4.4.ebuild b/dev-python/rosdistro/rosdistro-0.4.4.ebuild
deleted file mode 100644
index b25e4112a16e..000000000000
--- a/dev-python/rosdistro/rosdistro-0.4.4.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Tools to work with catkinized rosdistro files"
-HOMEPAGE="http://wiki.ros.org/rosdistro"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests --with-xunit test || die
-}