summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sh/sh-1.12.14.ebuild')
-rw-r--r--dev-python/sh/sh-1.12.14.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/sh/sh-1.12.14.ebuild b/dev-python/sh/sh-1.12.14.ebuild
deleted file mode 100644
index 6278d6e98ad6..000000000000
--- a/dev-python/sh/sh-1.12.14.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python subprocess interface"
-HOMEPAGE="https://github.com/amoffat/sh"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
-
- # https://github.com/amoffat/sh/pull/468
- "${FILESDIR}/sh-1.12.14-tests.patch"
-)
-
-python_test() {
- "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
-}