summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/spyder-line-profiler/spyder-line-profiler-0.2.1.ebuild')
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.2.1.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.1.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.1.ebuild
deleted file mode 100644
index 16a6a96a2d6b..000000000000
--- a/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_7 )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
-HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/line_profiler[${PYTHON_USEDEP}]
- >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]"
-
-DEPEND="test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-python_test() {
- virtx pytest -vv spyder_line_profiler/widgets/tests
-}