summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/terminado/terminado-0.6.ebuild')
-rw-r--r--dev-python/terminado/terminado-0.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/terminado/terminado-0.6.ebuild b/dev-python/terminado/terminado-0.6.ebuild
new file mode 100644
index 000000000000..4746ac57775e
--- /dev/null
+++ b/dev-python/terminado/terminado-0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.python.org/pypi/terminado https://github.com/takluyver/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ >=www-servers/tornado-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests --verbosity=3 || die
+}