summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/visitor/visitor-0.1.3.ebuild')
-rw-r--r--dev-python/visitor/visitor-0.1.3.ebuild28
1 files changed, 0 insertions, 28 deletions
diff --git a/dev-python/visitor/visitor-0.1.3.ebuild b/dev-python/visitor/visitor-0.1.3.ebuild
deleted file mode 100644
index 3ece48c4d529..000000000000
--- a/dev-python/visitor/visitor-0.1.3.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tiny pythonic visitor implementation"
-HOMEPAGE="https://github.com/mbr/visitor"
-# PyPI tarballs don't include tests
-# https://github.com/mbr/visitor/pull/2
-SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- py.test || die "Tests failed with ${EPYTHON}"
-}