summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xdis')
-rw-r--r--dev-python/xdis/Manifest1
-rw-r--r--dev-python/xdis/files/xdis-3.3.0-remove-pytest-runner-dep.patch33
-rw-r--r--dev-python/xdis/metadata.xml22
-rw-r--r--dev-python/xdis/xdis-3.6.0.ebuild44
4 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/xdis/Manifest b/dev-python/xdis/Manifest
deleted file mode 100644
index 1ee1a5138e1a..000000000000
--- a/dev-python/xdis/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xdis-3.6.0.tar.gz 144766 BLAKE2B e9a33443d42ff71194180f0bb20423783107d4b1e3d6c364b824011d916041500048345cac4853d1ebb6363edf8df542b0363650bba42e187986f50c9696051f SHA512 8b45ccd6976204004f27ee5b1a9da9b29ec0e28f4b462d862be5a1238d3ebd4a5d6f3df5607f3e2f037d80b2d3ae77ec4246ab1aa0671466c1e07e3a65453f3b
diff --git a/dev-python/xdis/files/xdis-3.3.0-remove-pytest-runner-dep.patch b/dev-python/xdis/files/xdis-3.3.0-remove-pytest-runner-dep.patch
deleted file mode 100644
index a412e515b813..000000000000
--- a/dev-python/xdis/files/xdis-3.3.0-remove-pytest-runner-dep.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From aabea1b295308b227bbaf4acd36f058121984791 Mon Sep 17 00:00:00 2001
-From: Brian Dolbec <dolsen@gentoo.org>
-Date: Tue, 28 Mar 2017 11:20:00 -0700
-Subject: [PATCH] remove-pytest-runner dep
-
----
- setup.py | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 138b769..5941951 100755
---- a/setup.py
-+++ b/setup.py
-@@ -5,7 +5,7 @@
- from __pkginfo__ import \
- author, author_email, \
- license, long_description, classifiers, \
-- modname, py_modules, setup_requires, \
-+ modname, py_modules, \
- scripts, short_desc, tests_require, \
- VERSION, web, zip_safe
-
-@@ -20,7 +20,6 @@ setup(
- name = modname,
- packages = find_packages(),
- py_modules = py_modules,
-- setup_requires = setup_requires,
- scripts = scripts,
- tests_require = tests_require,
- url = web,
---
-2.12.1
-
diff --git a/dev-python/xdis/metadata.xml b/dev-python/xdis/metadata.xml
deleted file mode 100644
index 02f9b35795a8..000000000000
--- a/dev-python/xdis/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <maintainer>
- <email>rb@dustyfeet.com</email>
- <name>Rocky Bernstein</name>
- </maintainer>
- <remote-id type="pypi">xdis</remote-id>
- <remote-id type="github">rocky/python-xdis</remote-id>
- </upstream>
- <longdescription>This Python module allows you to disassemble bytecode from
- different versions of Python than you are running on. It can marshal
- load Python bytecodes from different versions of Python. The
- command-line routine pydisasm will show disassembly output using Python
- 3.5 disassembly conventions
- </longdescription>
-</pkgmetadata>
diff --git a/dev-python/xdis/xdis-3.6.0.ebuild b/dev-python/xdis/xdis-3.6.0.ebuild
deleted file mode 100644
index 2e7b6918205f..000000000000
--- a/dev-python/xdis/xdis-3.6.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6)
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code disassembler and marshal routines"
-HOMEPAGE="https://github.com/rocky/python-xdis/ https://pypi.org/project/xdis/"
-# bad pypi source tarball - test failures
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/rocky/python-xdis/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/nose-1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/xdis-3.3.0-remove-pytest-runner-dep.patch"
-)
-
-S="${WORKDIR}/python-xdis-release-${PV}"
-
-python_test() {
- # Need to rm any pyc files to prevent test failures.
- rm -R "${S}"/test/__pycache__
- PYTHONPATH="${S}/test:${S}/test_unit:${BUILD_DIR}/lib" \
- esetup.py test || die "Tests failed under ${EPYTHON}"
-}