summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/yappi/yappi-0.93.ebuild')
-rw-r--r--dev-python/yappi/yappi-0.93.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/yappi/yappi-0.93.ebuild b/dev-python/yappi/yappi-0.93.ebuild
new file mode 100644
index 000000000000..7a18291a8cc8
--- /dev/null
+++ b/dev-python/yappi/yappi-0.93.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_{3,4}})
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="https://bitbucket.org/sumerc/yappi/"
+SRC_URI="https://bitbucket.org/sumerc/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}