summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cryptography/Manifest1
-rw-r--r--dev-python/cryptography/cryptography-1.0.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/cryptography/Manifest b/dev-python/cryptography/Manifest
index e23e1903c3e9..bf00855e8182 100644
--- a/dev-python/cryptography/Manifest
+++ b/dev-python/cryptography/Manifest
@@ -8,4 +8,5 @@ DIST cryptography-0.8.tar.gz 268083 SHA256 e54601e4dec2b8acb90f5ed3b93d23d280964
DIST cryptography-0.9.2.tar.gz 302972 SHA256 bc9ddd1442ce67a5bbd5598eced127de000da55f0ce25498b1174746c0290b3c SHA512 3d13f0284d484911b1f7067966f3727de9019d24af379b1adb1e0377888680b9385792e481888d2b357bce20f250a948c22b34743b4aeb955d736e8ae9ca88da WHIRLPOOL 0832bfdaff40e89750d92ffd5298be5c39fc1b4606ee7f769a68fb469e9e2175837f1b3f660f774a793538e050f2081fd69201f882a5bd77713e1bacd3115370
DIST cryptography-0.9.3.tar.gz 303075 SHA256 aed022f738dd9adb840d92960b0464ea1fbb222ba118938858eb93fe25151c2d SHA512 828dd6d3af940c91f77b9bcefb34ca9cc3ac05606d707889ff35bf708c3536414db46f8db7d7dcbffe2ad1f82834bc9edab1b28b05fee3f2a5f9f5a56abd697c WHIRLPOOL 33eb42741cf2426ffe16d50d0f555fee65637d812f9510016ceb708f9c591f38de2d65e4b4118f744ff9b73596727160501ec5d077bfe0935d088586909b979d
DIST cryptography-1.0.1.tar.gz 332242 SHA256 cfe3092a6a929bc3a97c3b752044b79d09c9b210860c7b4eb5061aea29dcbfd3 SHA512 a813084f09113baf17ea344dc2bc71fc09a164908661e8a469997c5212a30c09f65b87f84df0f2c70a38b3529faeb78e08430054d065bd46fc625a1bd62d1ddb WHIRLPOOL f7039799f11da6f95826936e5279d8e9be8971af33601058a910a34d62e1f53879ce93fb69dbd3909d3a2890680c1dabc3a5ce812b34c6882764aafd9ab0ce94
+DIST cryptography-1.0.2.tar.gz 332870 SHA256 d64cd491e91ddf642c643bea16532c2a2da2da054cca6df756edadd55a8bacca SHA512 f266fbee6ab06ed6a552599dffe6d3e959dd858e6be7b81c0d4489c384fbb2b5de5ecf4f1e43e1dacbaa6ddefd1562f10961caec73cb3ed256faa03a5d4eff85 WHIRLPOOL ba8c13df5c58ab551f43ddf51cde8e85835a06eda83e5a5039e32308431b6f365692b01ea343adba6fcafe80d045a04b8ef37324e5bf1ada0adef10752f1e321
DIST cryptography-1.0.tar.gz 331438 SHA256 211c02fe77d791d7fc437227ba1c046268d5da665e05d8a53fc19f4f74c21001 SHA512 a4e4f8b054a357e0856a67b246ba770f38222f45f0d8c3185bdfe20593f4d5a20d2082a0c7b9986d5b557dc2b43a0903bcb37eba10e4ca1d83f903fea6c39753 WHIRLPOOL c36bead358e8d30785f3d565366a0a8ec7b356cd31274aac7d0fe0286d36af52916fb3840000d22c53e487d26adb6d42b6dd69d1d7d5aed2fe20dc8cbef86e77
diff --git a/dev-python/cryptography/cryptography-1.0.2.ebuild b/dev-python/cryptography/cryptography-1.0.2.ebuild
new file mode 100644
index 000000000000..a005f87d060b
--- /dev/null
+++ b/dev-python/cryptography/cryptography-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# only works with >=pypy-2.6
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library providing cryptographic recipes and primitives"
+HOMEPAGE="https://github.com/pyca/cryptography/ https://pypi.python.org/pypi/cryptography/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="libressl test"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 python3_3 pypy)
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ipaddress[${PYTHON_USEDEP}]' python2_7 pypy)
+ >=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ~dev-python/cryptography-vectors-${PV}[${PYTHON_USEDEP}]
+ dev-python/iso8601[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ <dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CONTRIBUTING.rst README.rst )
+
+python_test() {
+ py.test -v -v -x || die "Tests fail with ${EPYTHON}"
+}