summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rosdistro/Manifest1
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.3.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index e164f3a9040b..372bc819cde3 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1,2 +1 @@
-DIST rosdistro-0.6.3.tar.gz 48789 BLAKE2B f26da2b2624501321033390d554559a0b807b224c35e96ff1643d6060e0225b9de6e2f9df354c5f6f13d277ba5b46453fe5db10d31cd5b05f50a78360d2b03dd SHA512 9fe50a9ed67d5772912ad7d15c60179894f3d775b593e4f42fff6c5221a77ea89176c9239ac0e962d2997eb6b1b365ad47da1080f69e62a4c75e1ea3f26294f0
DIST rosdistro-0.6.4.tar.gz 58603 BLAKE2B 9eed482987826b69eba51f1776df0d2285c496130d500f082f82fe7fbbb8e8d5767dcaec93582328a33c164a862ac2a46ac6d0ed0f770ebb16b25e680dc1e9af SHA512 92365b556cc6615245bd69cce35efb2fe879fe42fb4aafef08b2472c67b43e14e3088c1186e8b1d4f5f3781bfebbe826b3c361a9435ce27745a3506d20d40f85
diff --git a/dev-python/rosdistro/rosdistro-0.6.3.ebuild b/dev-python/rosdistro/rosdistro-0.6.3.ebuild
deleted file mode 100644
index e9ccf8b2beb3..000000000000
--- a/dev-python/rosdistro/rosdistro-0.6.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Tools to work with catkinized rosdistro files"
-HOMEPAGE="http://wiki.ros.org/rosdistro"
-if [ "${PV#9999}" != "${PV}" ] ; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
- https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz
- "
- KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- dev-python/catkin_pkg[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests --with-xunit test || die
-}