summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/kaptan/kaptan-0.5.12-r1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/kaptan/kaptan-0.5.12-r1.ebuild b/dev-python/kaptan/kaptan-0.5.12-r1.ebuild
index b3b88c26ac31..83c9dcc0eeaa 100644
--- a/dev-python/kaptan/kaptan-0.5.12-r1.ebuild
+++ b/dev-python/kaptan/kaptan-0.5.12-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
@@ -14,8 +14,6 @@ LICENSE="kaptan"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}
- >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]"
distutils_enable_tests pytest