summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pip/pip-21.1.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pip/pip-21.1.2.ebuild b/dev-python/pip/pip-21.1.2.ebuild
index 8dd2850878c5..15cfd6a1fe10 100644
--- a/dev-python/pip/pip-21.1.2.ebuild
+++ b/dev-python/pip/pip-21.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE="ssl(+),threads(+)"
inherit bash-completion-r1 distutils-r1
@@ -43,7 +43,9 @@ BDEPEND="
dev-python/pretend[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/scripttest[${PYTHON_USEDEP}]
- <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ ' python3_{7..9})
dev-python/werkzeug[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
)
@@ -72,6 +74,12 @@ python_test() {
return 0
fi
+ # virtualenv-16 doesn't support python3_10 yet is still required by pip test suite
+ if [[ ${EPYTHON} == "python3.10" ]]; then
+ ewarn "Skipping tests on ${EPYTHON} due to missing dependencies"
+ return 0
+ fi
+
local deselect=(
tests/functional/test_install.py::test_double_install_fail
tests/functional/test_list.py::test_multiple_exclude_and_normalization