summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.11.0_rc.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index f08d23c339f6..e709fb40534d 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
DIST qtlocation-everywhere-src-5.11.0-beta4.tar.xz 5520552 BLAKE2B b51c329738fb2d926cef11a4f0bbfd1bcfcac9170365896aa4e6d8752e3fbcc50530bbdf14d471e445315a765045ed216a9dd7695407e3b610bbca0a714ff164 SHA512 8e68df472c98d7c6aeb1f0d0a8444c3bb17ce92d96621454acc5ef86c02ad8f3576976b50d1ad83419e2b8439cafaa80d05d2605f753e56a2c86290cc9d6c272
+DIST qtlocation-everywhere-src-5.11.0-rc.tar.xz 5530380 BLAKE2B ee1074814a272dce3350814c5e3c3c4221ee35f3945948e934803f94aafcab8a8769ed7720f7deaac8a61615f32d2e7aca3112faa8673ecad78cb07042f0638a SHA512 72b1e3f351b64f8cd4c979325dd1916bf3f57ad1c31630dc21130c43269db75b2ac6a361cd18a5705d48e1fd870326e1de8001841a5d93b4bfe476524587b622
DIST qtlocation-opensource-src-5.7.1.tar.xz 3194112 BLAKE2B b5ac3bed420507c4a03b382c23d02cf0638c64e4921872930ec22394c3eaef7b7abaf7830d40c3aa2c9888e91724d5795b17a6d2a37f2f21b97285ef7d0dfd69 SHA512 a3e0318ad348edd6d9cb4762d4fc6230a47984fcf526f55cc2c9bc00e2e70fdb1380866ec8906e3f58669c62464f8747c948d85107a2d30be1e98da27c7739d4
DIST qtlocation-opensource-src-5.9.4.tar.xz 5405252 BLAKE2B 6474251b21baaac6182a0197a7736dcae86d0735e8be499c9bfefa639b3a45c750fa9bfef766849fbf6d7c5db518e5712e0862463e98168e2a3121582966d834 SHA512 a97de23a554f709a39ac8517de85c9beb7e1a8330ba3996593aeb3d64d1c5b8d8b08b0c94df435dcbb4ba5807e262ac6f87ec9620694805e0261a4b2ee8456cb
DIST qtlocation-opensource-src-5.9.5.tar.xz 5405920 BLAKE2B cd405d3a1eeed95c1c9f8759cc0d3c34d532de6f11c030296cb652e37aba66628578551fc73d5e283a373426b1e7b816b092cad1329d0a61f349650e88836a53 SHA512 80d8a8f3e82238c8a7f3e37999d5f118857e0037e60979de00219db45b3c716e6ac092f0b848c00cccbeb0ac19a1a2f4479bf92c7db701de1b3d239161d46d15
diff --git a/dev-qt/qtlocation/qtlocation-5.11.0_rc.ebuild b/dev-qt/qtlocation/qtlocation-5.11.0_rc.ebuild
new file mode 100644
index 000000000000..f791b5b325e3
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.11.0_rc.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}