summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtscript/qtscript-5.11.2.ebuild')
-rw-r--r--dev-qt/qtscript/qtscript-5.11.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-qt/qtscript/qtscript-5.11.2.ebuild b/dev-qt/qtscript/qtscript-5.11.2.ebuild
new file mode 100644
index 000000000000..70066980384a
--- /dev/null
+++ b/dev-qt/qtscript/qtscript-5.11.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE="+jit scripttools"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ scripttools? (
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod scripttools widgets \
+ src/src.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ JAVASCRIPTCORE_JIT=$(usex jit 'yes' 'no')
+ )
+ qt5-build_src_configure
+}