summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtspeech/qtspeech-5.15.0.ebuild')
-rw-r--r--dev-qt/qtspeech/qtspeech-5.15.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/qtspeech-5.15.0.ebuild b/dev-qt/qtspeech/qtspeech-5.15.0.ebuild
new file mode 100644
index 000000000000..12d0485fe59b
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-5.15.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Text-to-speech library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+# TODO: flite plugin - needs 2.0.0 (not yet in tree)
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/speech-dispatcher-0.8.7
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}"