summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtx11extras/qtx11extras-5.9.3.ebuild')
-rw-r--r--dev-qt/qtx11extras/qtx11extras-5.9.3.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-qt/qtx11extras/qtx11extras-5.9.3.ebuild b/dev-qt/qtx11extras/qtx11extras-5.9.3.ebuild
new file mode 100644
index 000000000000..545409027ab6
--- /dev/null
+++ b/dev-qt/qtx11extras/qtx11extras-5.9.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Linux/X11-specific support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[xcb]
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtwidgets-${PV} )
+"