summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_pose_estimation/hector_pose_estimation-0.2.0.ebuild')
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.2.0.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.2.0.ebuild
new file mode 100644
index 000000000000..702341304ef9
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"