summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_geometry/image_geometry-1.12.4.ebuild')
-rw-r--r--dev-ros/image_geometry/image_geometry-1.12.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/image_geometry/image_geometry-1.12.4.ebuild b/dev-ros/image_geometry/image_geometry-1.12.4.ebuild
new file mode 100644
index 000000000000..89bb2fdedb12
--- /dev/null
+++ b/dev-ros/image_geometry/image_geometry-1.12.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ and Python libraries for interpreting images geometrically"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ media-libs/opencv:=
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"