summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/moveit_msgs/moveit_msgs-0.9.1.ebuild')
-rw-r--r--dev-ros/moveit_msgs/moveit_msgs-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/moveit_msgs/moveit_msgs-0.9.1.ebuild b/dev-ros/moveit_msgs/moveit_msgs-0.9.1.ebuild
new file mode 100644
index 000000000000..4e01ed6ec6d6
--- /dev/null
+++ b/dev-ros/moveit_msgs/moveit_msgs-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/moveit_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/sensor_msgs
+ dev-ros/geometry_msgs
+ dev-ros/trajectory_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+ dev-ros/octomap_msgs
+ dev-ros/object_recognition_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages, services and actions used by MoveIt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"