summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/pointcloud_to_laserscan')
-rw-r--r--dev-ros/pointcloud_to_laserscan/Manifest1
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/pointcloud_to_laserscan/Manifest b/dev-ros/pointcloud_to_laserscan/Manifest
index 3ba78e8fb06e..b4c53bb46dba 100644
--- a/dev-ros/pointcloud_to_laserscan/Manifest
+++ b/dev-ros/pointcloud_to_laserscan/Manifest
@@ -1 +1,2 @@
DIST pointcloud_to_laserscan-1.3.0.tar.gz 6115 SHA256 704b79a179f415a71acb4c4c42793a49bd0a018ec6b1e2c71a3592decd8f4585 SHA512 a41b1c42048dde6ee73ca33f71e8e39354e4ebc0e91274eee590497d703c6ea9e0954e79d24cf828c3c1eac68377f894c728cff26b46a73f0d8cd3d7f6195c00 WHIRLPOOL edb45d94730c36c1fc617df43d52d24c15d23f05c4e9452a12d610578c175396dbe2129be51e00cf9191696284f1b7f3cfd4a6b670cf2adb5c2b87b230d93816
+DIST pointcloud_to_laserscan-1.3.1.tar.gz 6239 SHA256 345161557c13c395d89aaf63c44d00514e81208db806814d9596495e6396ce41 SHA512 2356de7b7778b396775f4e2a9b2b9fe9f0329f514577820686c1d477fcd9423622df0351551bfe9111ef33a105859f42612e7d8e3c2c39328e224a836fc4d34b WHIRLPOOL 3999c0f469e9efebcf78614abd12152776548ed013daf1fa7ccf66fce422421aa933972c7e0566516e158eb6d7535e759a4601b0749e6d010bcd26c0b34b15e2
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.1.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.1.ebuild
new file mode 100644
index 000000000000..c7f35e01db90
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+"
+DEPEND="${RDEPEND}"