summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/qt_gui/qt_gui-0.3.4.ebuild')
-rw-r--r--dev-ros/qt_gui/qt_gui-0.3.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/qt_gui/qt_gui-0.3.4.ebuild b/dev-ros/qt_gui/qt_gui-0.3.4.ebuild
new file mode 100644
index 000000000000..14b66a390dfa
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"