summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/qt_gui')
-rw-r--r--dev-ros/qt_gui/Manifest1
-rw-r--r--dev-ros/qt_gui/qt_gui-0.3.9.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/qt_gui/Manifest b/dev-ros/qt_gui/Manifest
index ad9b8461e86a..d77d2cae3d56 100644
--- a/dev-ros/qt_gui/Manifest
+++ b/dev-ros/qt_gui/Manifest
@@ -2,3 +2,4 @@ DIST qt_gui_core-0.3.4.tar.gz 87974 BLAKE2B 7550100c865167a5e617db6ddbf2c2fcdb9f
DIST qt_gui_core-0.3.5.tar.gz 90480 BLAKE2B cdbe0a8b8ddeb430658138fbe5dceae2ed233dd906d4b8eadedf5a1640d9ec8bd50adcf396c84199796798d41c3bf7247c8e11ac7675e0aa283ba33ad68dbfba SHA512 1c307e220d8484013e83cf2e3e4b6d674db3d6273f08ffc1ab928f92c1a4009d3b3d8d011f88b40e73ad371be34c7d4a790a78a47361ddb1c44b1a44970bf955
DIST qt_gui_core-0.3.6.tar.gz 90705 BLAKE2B 7002d22b8deb2d8cd95ddfffcfd60e8cf092a1ada86a5fb6c666b41689d235f000a9375bf2389a082e187b4aa69accf8da1b7ce1b29c980d736fb9860e10a5d5 SHA512 bdd824010552af098f2b9294aef18c73413a1f76fe1cf61daccf9d9f17d7d16f6a9a1ec11c157460c1b89d6c44f21fccbdcab813ca42c052a6bc46de52f86ab0
DIST qt_gui_core-0.3.8.tar.gz 91248 BLAKE2B 9ed159b8d065e7b2a44dcf9ac496a699675e5ec41d5ed222413894f098e122b092c976c934dc37a99846e0fe80858fb377bf937b3eabc3f0c6df126de7944e88 SHA512 aec926adffc9f1ab84d7d5cccb207d87254496b37e9e2e4c430de191917823424751206647d61821a65dec0aad3241dab22c85f21980fbe1a4bf114bb2c29d70
+DIST qt_gui_core-0.3.9.tar.gz 91495 BLAKE2B c0f2f2b9231a42da68c0032bfb192a47060f4b0915952b77750985be00023f22678480605990a79016b8ed906cacbdb9cd7eafabbb917b06f891f6b7817a999c SHA512 3e7e45001f1749e3ca75c6b33e3e7a131a314a5ec66925b86f2617f6f749f4c2093d33420bbe0f148faa44fb1fb3071241e47180d3c56ed9d1f7a2befb006a95
diff --git a/dev-ros/qt_gui/qt_gui-0.3.9.ebuild b/dev-ros/qt_gui/qt_gui-0.3.9.ebuild
new file mode 100644
index 000000000000..ef3a31a6467e
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.3.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"