summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosbag_storage/rosbag_storage-1.14.3-r1.ebuild')
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-1.14.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.14.3-r1.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.14.3-r1.ebuild
new file mode 100644
index 000000000000..8cd7afb67508
--- /dev/null
+++ b/dev-ros/rosbag_storage/rosbag_storage-1.14.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge
+ app-crypt/gpgme
+ dev-ros/pluginlib
+ dev-ros/cpp_common
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/roslz4
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-libs/console_bridge:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}"