summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/roslz4/roslz4-9999.ebuild')
-rw-r--r--dev-ros/roslz4/roslz4-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/roslz4/roslz4-9999.ebuild b/dev-ros/roslz4/roslz4-9999.ebuild
new file mode 100644
index 000000000000..4d4bc7b747b8
--- /dev/null
+++ b/dev-ros/roslz4/roslz4-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/lz4"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"