summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosbag_storage/test_rosbag_storage-1.14.3.ebuild')
-rw-r--r--dev-ros/test_rosbag_storage/test_rosbag_storage-1.14.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag_storage/test_rosbag_storage-1.14.3.ebuild b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.14.3.ebuild
new file mode 100644
index 000000000000..31f2c38f62c9
--- /dev/null
+++ b/dev-ros/test_rosbag_storage/test_rosbag_storage-1.14.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag_storage"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rosbag_storage
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ test? ( dev-cpp/gtest )"