summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-9999.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-9999.ebuild b/dev-ros/test_tf2/test_tf2-9999.ebuild
new file mode 100644
index 000000000000..a84aea70553b
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_msgs
+ sci-libs/orocos_kdl
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? ( dev-cpp/gtest )"
+
+src_install() {
+ :
+}