summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf_conversions')
-rw-r--r--dev-ros/tf_conversions/tf_conversions-1.13.2.ebuild10
-rw-r--r--dev-ros/tf_conversions/tf_conversions-9999.ebuild12
2 files changed, 11 insertions, 11 deletions
diff --git a/dev-ros/tf_conversions/tf_conversions-1.13.2.ebuild b/dev-ros/tf_conversions/tf_conversions-1.13.2.ebuild
index 16eff00ad679..a23bc799bb84 100644
--- a/dev-ros/tf_conversions/tf_conversions-1.13.2.ebuild
+++ b/dev-ros/tf_conversions/tf_conversions-1.13.2.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/ros/geometry"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Conversion functions to convert common tf datatypes into identical datatypes used by other libraries"
+DESCRIPTION="Functions to convert common tf datatypes into those used by other libraries"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/kdl_conversions
dev-ros/tf[${PYTHON_USEDEP}]
sci-libs/orocos_kdl:=
- dev-cpp/eigen:3
dev-ros/rospy[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/tf_conversions/tf_conversions-9999.ebuild b/dev-ros/tf_conversions/tf_conversions-9999.ebuild
index 9e9aa0f339c9..a23bc799bb84 100644
--- a/dev-ros/tf_conversions/tf_conversions-9999.ebuild
+++ b/dev-ros/tf_conversions/tf_conversions-9999.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
CATKIN_HAS_MESSAGES=yes
ROS_REPO_URI="https://github.com/ros/geometry"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Conversion functions to convert common tf datatypes into identical datatypes used by other libraries"
+DESCRIPTION="Functions to convert common tf datatypes into those used by other libraries"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/kdl_conversions
dev-ros/tf[${PYTHON_USEDEP}]
sci-libs/orocos_kdl:=
- dev-cpp/eigen:3
dev-ros/rospy[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-cpp/gtest dev-python/nose[${PYTHON_USEDEP}] )"