summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rosgraph_msgs/Manifest1
-rw-r--r--dev-ros/rosgraph_msgs/metadata.xml5
-rw-r--r--dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.1.ebuild22
-rw-r--r--dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/rosgraph_msgs/Manifest b/dev-ros/rosgraph_msgs/Manifest
new file mode 100644
index 000000000000..b49b3901f3c4
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/Manifest
@@ -0,0 +1 @@
+DIST ros_comm_msgs-1.11.1.tar.gz 2433 SHA256 e4c45e4504ec9751c2f89fea9f1d4fcfeba563435a4445a299b153255705e793 SHA512 e1b9c96b8973ae609e80cb80da0cd32b325040a6e06ae89984e4447027bae5945a04ae0e7143de0ef93cc6f1a6f6cf3c0369b4bd3264ec6d45186e158b47dd96 WHIRLPOOL df84c7baeaf3b3f366adf9560b62693ac9d12e29d49933f3d9ee364273ad7e79dffaac4d5f7cd094529edab100772a956b3e0ee598374b492876f1592fccd8c4
diff --git a/dev-ros/rosgraph_msgs/metadata.xml b/dev-ros/rosgraph_msgs/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.1.ebuild b/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.1.ebuild
new file mode 100644
index 000000000000..7fb8185960c7
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/rosgraph_msgs-1.11.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/ros_comm_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages relating to ROS comm"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild b/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild
new file mode 100644
index 000000000000..7fb8185960c7
--- /dev/null
+++ b/dev-ros/rosgraph_msgs/rosgraph_msgs-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/ros_comm_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages relating to ROS comm"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"