summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/Manifest5
-rw-r--r--dev-ruby/activeldap/activeldap-4.0.6.ebuild39
-rw-r--r--dev-ruby/activeldap/activeldap-6.1.0-r1.ebuild (renamed from dev-ruby/activeldap/activeldap-5.2.3.ebuild)16
-rw-r--r--dev-ruby/activeldap/activeldap-7.0.0.ebuild (renamed from dev-ruby/activeldap/activeldap-5.2.4.ebuild)23
-rw-r--r--dev-ruby/activeldap/metadata.xml2
5 files changed, 20 insertions, 65 deletions
diff --git a/dev-ruby/activeldap/Manifest b/dev-ruby/activeldap/Manifest
index 798a6501f7dd..19f5ac1847d4 100644
--- a/dev-ruby/activeldap/Manifest
+++ b/dev-ruby/activeldap/Manifest
@@ -1,3 +1,2 @@
-DIST activeldap-4.0.6.gem 225280 BLAKE2B 0f03ef95f3d0600d2661eab048c8dda3fbabe519add67f7785895e346d835d1e0396270f829f16a982f12863c80378be2f4f7ff7cf84016007b005b1914cec15 SHA512 03053e3798b557c73c3a0918b72d1d3c2cada4da3475913ef17a6f9f2f1ac1e102052459ef1a6d8c25ce41382b64c1a3097ccba1c768497a33a3a971b9778d3b
-DIST activeldap-5.2.3.gem 226304 BLAKE2B 5ac747f9c854071da941bd7dc3bbf151eb9f6b190a725b0daca9a9c76b1aafa9fcb609c16098924c3f9bda6f25d9968c4a715a0f2994333c233a950f809cf862 SHA512 30fb4b70975e5a911d736ce8579f3ff0c13d326499660a6fdd25bc4e4d20ad615c038c0b50bdf1722775f6313e9c132a004c86fdb9d3a356f78171f78c5d171b
-DIST activeldap-5.2.4.gem 226304 BLAKE2B f13b5a1cf423b44087d55d3a4957be1444d598ab1d1bd7d83ee545a2806b77b47124edcb326fc567eb06e866c62a2ad0c3dafd903232588f824bc2978c197d60 SHA512 da37cfa20c8be7151669ba3b409994c668b037a2f318b1b034f6fa9c0e56a9a778b03a26415cbd98c8ba3fa1d487d42343bc0532665c1037880e75474a1c708f
+DIST activeldap-6.1.0.gem 227328 BLAKE2B 48cd393a294b677b373461701773d3d0c18cbe9ee5124bcbafe392ee664a0e1045feb2d808734988bfceaaf7ae7b276ea12615ae30bb8109d63daf4b6a8cbed5 SHA512 b8a8d1346d75ae1ddd15b919f2a7afbec3e62b4248144ece3e1324892899735b05aa221ecec7c07f6273f35a6ffdacf4858d57326fb9b8c096f358652ef0b99d
+DIST activeldap-7.0.0.gem 227840 BLAKE2B 2bf720efa60f2233180cf73a79da61058398a7409319c468ee96938091fd3d4eeebc904e3d8c55f51d1ca9a22f1b22e27554b78910065022ce9ebb92a883c256 SHA512 b4df5307583fc29abb74cdfd1d3b62f4bf03525e4a81397b32522ce84ee49f58fae27a7e9ba62490cfe49daa27be67440ccbaca25ba15553845d9e4a6e693bda
diff --git a/dev-ruby/activeldap/activeldap-4.0.6.ebuild b/dev-ruby/activeldap/activeldap-4.0.6.ebuild
deleted file mode 100644
index 7d974c43a6c6..000000000000
--- a/dev-ruby/activeldap/activeldap-4.0.6.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
-RUBY_FAKEGEM_EXTRAINSTALL="po"
-
-inherit ruby-fakegem
-
-MY_P="${P/ruby-/}"
-DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
-HOMEPAGE="https://github.com/activeldap/activeldap"
-
-LICENSE="GPL-2"
-SLOT="4"
-KEYWORDS="~amd64"
-IUSE=""
-
-# Most tests require a live LDAP server to run.
-RESTRICT="test"
-
-ruby_add_rdepend "
- >dev-ruby/activemodel-4.0.0:*
- dev-ruby/locale
- dev-ruby/ruby-gettext
- dev-ruby/gettext_i18n_rails
- || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
-
-all_ruby_install() {
- all_fakegem_install
-
- dodoc doc/text/*
-
- insinto /usr/share/doc/${PF}
- doins -r examples
-}
diff --git a/dev-ruby/activeldap/activeldap-5.2.3.ebuild b/dev-ruby/activeldap/activeldap-6.1.0-r1.ebuild
index 9b763decfa5f..0ddf0824c69f 100644
--- a/dev-ruby/activeldap/activeldap-5.2.3.ebuild
+++ b/dev-ruby/activeldap/activeldap-6.1.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
+RUBY_FAKEGEM_EXTRADOC="TODO doc/text/*"
RUBY_FAKEGEM_EXTRAINSTALL="po"
inherit ruby-fakegem
@@ -15,7 +15,7 @@ DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interf
HOMEPAGE="https://github.com/activeldap/activeldap"
LICENSE="GPL-2"
-SLOT="5"
+SLOT="$(ver_cut 1)"
KEYWORDS="~amd64"
IUSE=""
@@ -23,7 +23,7 @@ IUSE=""
RESTRICT="test"
ruby_add_rdepend "
- >dev-ruby/activemodel-4.0.0:*
+ >=dev-ruby/activemodel-5.2.0:*
dev-ruby/builder
dev-ruby/locale
dev-ruby/ruby-gettext
@@ -34,7 +34,5 @@ all_ruby_install() {
all_fakegem_install
dodoc doc/text/*
-
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
}
diff --git a/dev-ruby/activeldap/activeldap-5.2.4.ebuild b/dev-ruby/activeldap/activeldap-7.0.0.ebuild
index 69bfdaa2d281..1540a3004f70 100644
--- a/dev-ruby/activeldap/activeldap-5.2.4.ebuild
+++ b/dev-ruby/activeldap/activeldap-7.0.0.ebuild
@@ -1,13 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
+EAPI=8
+USE_RUBY="ruby31 ruby32"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
+RUBY_FAKEGEM_EXTRADOC="TODO doc/text/*"
RUBY_FAKEGEM_EXTRAINSTALL="po"
+# Most tests require a running LDAP server
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
inherit ruby-fakegem
MY_P="${P/ruby-/}"
@@ -15,15 +18,11 @@ DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interf
HOMEPAGE="https://github.com/activeldap/activeldap"
LICENSE="GPL-2"
-SLOT="5"
+SLOT="$(ver_cut 1)"
KEYWORDS="~amd64"
-IUSE=""
-
-# Most tests require a live LDAP server to run.
-RESTRICT="test"
ruby_add_rdepend "
- >dev-ruby/activemodel-4.2.0:*
+ >=dev-ruby/activemodel-5.2.0:*
dev-ruby/builder
dev-ruby/locale
dev-ruby/ruby-gettext
@@ -34,7 +33,5 @@ all_ruby_install() {
all_fakegem_install
dodoc doc/text/*
-
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
}
diff --git a/dev-ruby/activeldap/metadata.xml b/dev-ruby/activeldap/metadata.xml
index 5dc46abd2d2e..80d832f99f62 100644
--- a/dev-ruby/activeldap/metadata.xml
+++ b/dev-ruby/activeldap/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>ruby@gentoo.org</email>