summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activeldap')
-rw-r--r--dev-ruby/activeldap/Manifest1
-rw-r--r--dev-ruby/activeldap/activeldap-5.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/activeldap/Manifest b/dev-ruby/activeldap/Manifest
index 756ff7685c92..73f94e2a29a9 100644
--- a/dev-ruby/activeldap/Manifest
+++ b/dev-ruby/activeldap/Manifest
@@ -1 +1,2 @@
DIST activeldap-4.0.6.gem 225280 SHA256 2b3660db97d49569eb514d1ab81a01eb3bbed7427cb95f38fef53eac3227be3e SHA512 03053e3798b557c73c3a0918b72d1d3c2cada4da3475913ef17a6f9f2f1ac1e102052459ef1a6d8c25ce41382b64c1a3097ccba1c768497a33a3a971b9778d3b WHIRLPOOL 4a9d282c8042feeeda3119c524e42fe783fafb1c040e09a5e7099c3a934ace0db9babed286334d125ed6e162fcbfc2284398e883f1285ae56176affc65f3abbd
+DIST activeldap-5.1.0.gem 224768 SHA256 8e029e35315c2cb6ff0bcc0f5e4dc88d42b4def3ed97c741538b11817c704ca5 SHA512 8bed994f1477429c96001ce69be89581742e2ed00e48a8a59b9eeb08db6e327faf0a1b8eb3746e7f8680a8814d90bf3e1c2fa4f160d661358c1d61b792e3d54d WHIRLPOOL 879e16823da16f362468b3606a9fa8171b91db9179ce7e6dbba48bae06a08fe422c2d7035c40b9371d431e05db761b8ad319feb22607e5b359717b1387a57ea2
diff --git a/dev-ruby/activeldap/activeldap-5.1.0.ebuild b/dev-ruby/activeldap/activeldap-5.1.0.ebuild
new file mode 100644
index 000000000000..74599bd08b99
--- /dev/null
+++ b/dev-ruby/activeldap/activeldap-5.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile TODO doc/text/*"
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="https://github.com/activeldap/activeldap"
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_rdepend "
+ >dev-ruby/activemodel-4.0.0:*
+ dev-ruby/locale
+ dev-ruby/ruby-gettext
+ dev-ruby/gettext_i18n_rails
+ || ( >=dev-ruby/ruby-ldap-0.8.2 dev-ruby/ruby-net-ldap )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc doc/text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}