summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/atomic')
-rw-r--r--dev-ruby/atomic/atomic-1.1.101-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/atomic/atomic-1.1.101-r1.ebuild b/dev-ruby/atomic/atomic-1.1.101-r1.ebuild
new file mode 100644
index 000000000000..a30e90d0040b
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.101-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' \
+ -e '/extensiontask/,/end/ s:^:#:' Rakefile || die
+}